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Objective
The purpose of this document is to help you with migrating databases prior to 3.9 to 
work with Daylite 3.9.

Audience
This document is useful for users and/or administrators who are responsible for 
migrating pre-Daylite 3.9 databases to work with Daylite 3.9.      
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System requirements
• Tiger users should use Mac OS X 10.4.11 at minimum. Leopard users should use 

Mac OS X 10.5.6 or higher versions.
• 1 GHz G4 or higher Universal Binary supported. (Server may require a faster 

machine.)
• 1 GB RAM and 200 MB hard-disk space. Hard-disk space requirements may vary 

depending on the size of your database.
• 1024 x 768 or higher screen resolution.

If you are using an old version of Daylite and have not updated, keep in mind there 
have been significant changes with each new release. See the release history in our 
knowledge base for more information.

Note: For existing users, we recommend that you allocate some time for the migration 
process. Or, you could do it when you have some down time. 
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Overview
Starting from v 3.9, Daylite and Daylite Server Admin exist as 2 different components. 
In a multi-user environment, you would need both Daylite and Daylite Server Admin; 
however, single-users don’t need Daylite Server Admin. Daylite Server Admin is the 
central control for the new offline system and the Daylite Touch infrastructure. A part 
of this infrastructure is a new, more powerful, more scalable, more future friendly 
database engine that replaces OpenBase (the old database system). The new 
database system is powered by Postgres, a proven, popular SQL database engine.

Daylite Server Admin
We now have a dedicated Daylite Server Admin application. This new server 
component is required when sharing databases, synchronizing with offline databases 
or with Daylite Touch. Daylite Server Admin is only required on the “server” machine. 
It is not required on all computers. Client computers that run Daylite have their own 
environment created by the application. Daylite Server Admin also offers centralized 
licensing for Daylite and DMI.

Note: For more information about Daylite Server Admin, click here.
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Networking and port forwarding
Daylite can connect to any database that resides on the server either locally or 
remotely. Users who wish to configure access to server over the internet or VPN 
should specify certain settings. For example, consider you are working from home or 
on the road and want remote access to Daylite Server/Touch Server. If you've 
configured the network settings, then Daylite can connect to Daylite Server and your 
device can connect to the Touch Server automatically. Keep in mind that local access 
is always enabled when the server is running. Note: Remote access is not 
recommended for single users. Single users should sync over the Wi-Fi network to 
avoid unnecessarily complex setup.

You should specify the external host name and enable automatic port forwarding to 
be able to connect remotely.

• The external host name should be a static IP (Public) address. Otherwise, if you 
have a domain name set up, you can enter it here. The external host name you 
specify here is commonly used by both Daylite and Daylite Touch for connecting 
remotely. For more information about static IP’s, click here.

• The Network pane displays the ports that are used by Daylite Server and Touch 
Server. You can turn "On" automatic port forwarding if your firewall or router 
supports it. This tells the router how to pass a connection to the server machine 
automatically when you are trying to connect externally. If your firewall or router 
does not allow for automatic port forwarding, then you'll have to manually go into 
your firewall or router and open these ports. For more information about router 
support and port forwarding, click here or refer to your router’s manual.

• Local network access: You can enter a domain name that is accessible throughout 
the network and also VPN, if applicable. The internal host name you specify is 
commonly used by both Daylite and Daylite Touch for connecting remotely through 
VPN.

Using Dynamic DNS services

 If you don’t have a static IP or domain name, you can use services such as www.no-
ip.com and/or www.dyndns.com for remote access.
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Changes to licensing
In a multi-user environment, you must add all Daylite, DMI, DPS, and Daylite Touch 
licenses into Daylite Server Admin application on your server machine. This is called 
centralized licensing. There is no need to add licenses on every computer running 
Daylite. Single-users must add their license in Daylite.

Daylite licensing works on concurrent use model. You only need licenses for the 
number of people that will use Daylite at the same time on the same or different 
databases. The licensing model for Daylite Touch requires 1 license to support all your 
devices. For example, a Daylite Touch license supports any number of iPhones, iPods, 
and iPads for a single Daylite user. With one license, you will be able to connect to 
your database on multiple devices and synchronize with the Touch server concurrently.

When you are offline, you’ll use 1 license. You release the license when you go back 
online. For more information, see Help > Daylite Server Admin Help.

Migrating pre-Daylite 3.9 databases
Pre-Daylite 3.9 databases should be migrated to work with Daylite 3.9. Please verify 
the following check list before you begin.

Pre-migration check list:

• Backup your database by choosing File > Database > Quick Backup.

• Write down the name of the database you wish to migrate. This is especially 
important when you have multiple databases. You can see your database name in the 
toolbar located at the top of the Daylite window.

• Keep your license information handy before you migrate.

a. For single users:

       

             Daylite user with 1 computer

1. Go to the Synchronization pane of Daylite Preferences and turn synchronization  
    “Off” (not to be confused with offline users). 
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2. Download Daylite 3.9 and install it.
3. Launch Daylite 3.9.
4. Choose Daylite > Personal Licenses to add your license.
5. Choose File > Database > Migrate Database.
6. Select a database to migrate. Click Continue.
7. Enter the credentials for a database user with administrative privileges.
8. Click Migrate.
    The migration tool migrates the selected database to Daylite 3.9. Once migration  
    is completed, it displays "Migration Succeeded." Your password will be reset and 
    the new password will be displayed. You can email, save, or print the new 
    passwords.
9. Click Close.
  
Note: In some rare cases, the migrator may report that the database needs to be 
processed. Follow the on-screen prompts to be connected with Marketcircle support.

b. For multi users:

Note: 
Changing your server: If you plan to migrate your database and use a new 
machine as your server, then do the following:

1. Perform the migration on the same machine having Daylite 3.8 or earlier 
version.
2. Move the database backups to the new computer.
3. Install Daylite 3.9 and Daylite Server Admin on the server machine.
4. Restore the databases on the server machine. 

  
   Multiple Daylite users sharing one database

    
1. Go to the Synchronization pane of Daylite Preferences and turn synchronization  
   “Off” for each user (not to be confused with offline users).
2.  For offline users: 

• All offline databases should be synced prior to migration.
• Backup the master database. Make sure that no user uses Daylite 3.8 or even 

3.8 offlines. 
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3. Download Daylite Server from Marketcircle website and install it on the server 
    machine. This install includes Daylite Server Admin application and Daylite Server 
    components. 
4. Launch Daylite Server Admin.
5. From the Daylite Server Admin First Run window, select Migrate an Existing 
    Database.
    The Daylite Migrator window opens.
6. Select a database to migrate. Click Continue.
7. Enter the credentials for a database user with administrative privileges.
8. Click Migrate.
    The migration tool migrates the selected database to Daylite 3.9. Once migration 
    is  completed, it displays "Migration Succeeded." Your passwords will be reset and 
    the new passwords will be displayed. You can email, save, or print the new 
    passwords.
9. Click Close.
    The migrated database name shows up in the Databases pane of Daylite Server 
    Admin.    
10. Add licenses on Daylite Server Admin. Click Licenses and enter the serial number 
      and license key. 
11. Download Daylite 3.9 on all user machines.
12. Ensure that you recreate the offlines.

Note:  In some rare cases, the migrator may report that the database needs to be 
processed. Follow the on-screen prompts to be connected with Marketcircle support.

Please keep in mind that to work with Daylite Server Admin, you should be logged 
into your computer as an administrator. You'll be required to authenticate before 
making any changes on Daylite Server Admin. Once you start using Daylite Server 
Admin, you can also migrate subsequent databases by doing the following.  

To migrate a Daylite database

1. Working from the Daylite Server Admin, choose File > Migrate Database.
    The Daylite Migrator window opens.
2. Select a database to migrate. Click Continue.
3. Enter the credentials for a database user with administrative privileges.
4. Click Migrate.
    The migration tool migrates the selected database to Daylite 3.9. Once migration 
    is completed, it displays "Migration Succeeded" and tells you the new passwords  
    for all users. You can email, save, or print the new passwords.
5. Click Close.
    The migrated database name shows up in the Databases pane of Daylite Server 
    Admin. You can select the database to view additional details.
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c. For single users with 1 desktop and 1 laptop 

          

        Single user with a desktop and laptop 

In this case, follow the same procedure described for multi-users.

Migrating to Daylite 3.9 if you have multiple users on the same machine

If you have multiple user accounts for Daylite on the same machine and you want to 
share a database among those users, it is recommended that you install Daylite Server 
Admin on that machine and connect to the shared database from Daylite.

Note: Be careful not to migrate a database in both the personal and shared 
environments. The migration alert will come up for both. Click “Never Migrate” in 
Daylite if you’ve already migrated using Daylite Server Admin.

Uninstalling OpenBase
If you were using Daylite 3.8 or lower versions and currently switch to Daylite 3.9, then 
the folder containing the old version of Daylite is renamed as Daylite 3 Legacy in your 
Applications. This folder has Daylite 3.8 or older version of the application you were 
using and also a Daylite Legacy Uninstaller. For removing Daylite 3.8 (or older version 
of the application) and OpenBase Database Engine, you should run the Daylite Legacy 
Uninstaller. 
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Help and other resources
There are a number of resources available to help you learn more about Daylite Server 
Admin and to provide answers when you have technical questions.

• Apple Help offers step-by-step instructions and tips for making the most 
out of Daylite Server Admin. While using Daylite Server Admin, choose 
Help > Daylite Server Admin Help.

• The support website and knowledge base has up-to-date articles and 
movies that can help you solve technical difficulties. Visit http://
www.marketcircle.com/help/index.html.

• Visit http://forums.marketcircle.com to share ideas, tips, and questions with 
other users. Marketcircle engineers, designers, and support staff also share 
their knowledge on the forums.
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Under the copyright laws, this manual may not be copied, in whole or in part, without the written 
consent of Marketcircle Inc.

Every effort has been made to ensure that the information in this manual is accurate. Marketcircle is not 
responsible for printing or clerical errors.
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Phone: +1 905 480 5555
Fax: +1 905 248 3101
Email: info@marketcircle.com
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