Billings 3 Compatibility

Info: This page is for legacy software and has been archived. This will not receive updates in the future


Alert! Billings 3 is not supported beyond Mac OS 10.7 and iOS 7. Billings 3 no longer receives updates or customer support. If you are using Billings 3 consider updating to Billings Pro


If you're a Billings 3 user that's running OS X Lion, please use this build:

  • Billings 3.7.8 - (Requires Mac OS X 10.7.1 - 10.7.5)

Click here to download.


If you're a Billings 3 user that's running *OS X Mountain Lion, please use this build:

  • Billings 3.7.8 (Requires Mac OS X 10.8.1 - 10.8.5)

Click here to download.


Support and future development for the Billings 3 family of applications ceased as of June 30, 2014.

For upgrade options to Billings Pro which is supported on the latest Mac OS X and iOS versions, please contact our customer support team.

For Billings 3 users, the previous knowledge base can be found here.

Was this article helpful?


Thanks for your feedback


 please wait...
 

Still can't find what you're looking for?