Billings Pro Compatibility Guide

In many workplaces, it is not unusual to have multiple Macs, iPhones and iPads each running different versions of Apple's operating systems. While it is best to keep all devices up to the latest version, this isn't always possible.

Here is a quick guide to help you understand what versions of Mac OS X and iOS your Billings Pro applications can be safely run on.

Attention Billings Pro Self-Serve Customers! DO NOT update your Server computer to macOS High Sierra, Billings Pro Server Admin is not compatible. Timecard is also not compatible for Self-Serve customers on High Sierra.

The Billings Pro app is compatible and safe to update to High Sierra for Hosted and Self-Serve Customers.

If you are unsure if you use Billings Pro Hosted or Self-Serve contact support before upgrading macOS.


Billings Pro

  10.13 10.12 10.11 10.10 10.9 10.8 10.7 10.6
Billings Pro on the Mac ✓* ✓* ✕*
Billings Pro Server ✕* ✕*
iPhone & iPad iOS 11
✓*
iOS 10
iOS 9
iOS 8

*indicates there is additional information related to compatibility status. Click the status indicator within the chart for details.

Billings 3

Info: Billings 3 is not supported beyond Mac OS 10.7 and iOS 7. Billings 3 no longer receives updates or customer support. If you are using Billings 3 consider updating to Billings Pro


Was this article helpful?


Thanks for your feedback


 please wait...
 

Still can't find what you're looking for?