Marketcircle Compatibility

Check this page for updates on the compatibility of our apps with Apple’s macOS Mojave and iOS 12.

macOS Mojave

Daylite Cloud

Daylite and Daylite Mail Assistant for Mac Requires Daylite 6.6 or higher
See notes below.

If Daylite Mail isn't loading, follow these instructions.

Billings Pro Cloud

Billings Pro for Mac Compatible

iOS 12

Daylite Cloud

Daylite for iOS Compatible

Billings Pro Cloud

Billings Pro for iOS Compatible

Attention Self-Serve Customers

Daylite Self-Serve and Billings Pro Self-Serve will not be made compatible with macOS Mojave and iOS 12 and support for Self-Serve products will end Feb 28, 2019 as mentioned here.

If you want to update your operating system, we recommend you move to Daylite Cloud and contact us about moving to Billings Pro Cloud to make sure you’re compatible.

Getting Daylite for macOS Mojave

Daylite 6.6.0 works on Mojave only. On macOS 10.10 to 10.13 continue to use Daylite 6.5.11.

Once you have migrated to Mojave, you can update Daylite by going to Daylite → Check for Updates. You will get the correct version of Daylite for your OS.

Alternatively, once you've upgraded to Mojave, you can download Daylite here.

To enable DMA on Mojave, please follow the steps in this support article.

Last updated Sunday, September 23, 2018 10:00 p.m. EST