Application Downloads

Daylite for macOS icon Daylite & Mail Assistant for macOS

Requires macOS 10.13.6 or later

Daylite for iOS icon Daylite for iOS (App Store)

Requires iOS 13.4 or later

Billings Pro for macOS icon Billings Pro for macOS

Requires macOS 10.13 or later

Billings Pro for iOS icon Billings Pro for iOS (App Store)

Requires iOS 10 or later

We are always working hard to ensure our apps are supported on the latest offical releases from Apple. Consider beta versions of iOS and macOS as unsupported. If you are running a Public Beta of iOS or macOS and having a problem, please let us know.

Periodically we will increase the minimum operating system requirements for security reasons, or to allow us to bring you new functionality only supported on newer versions. We highly encourage all customers to update to the latest verions of iOS and macOS for security and compatibility with our apps.